CSTeX: Multiple vulnerabilities — GLSA 200711-34

Multiple vulnerabilities were discovered in CSTeX, possibly allowing to execute arbitrary code or overwrite arbitrary files.

Affected Packages

app-text/cstetex on all architectures
Affected versions < 2.0.2-r2
Unaffected versions

Background

CSTeX is a TeX distribution with Czech and Slovak support. It is used for creating and manipulating LaTeX documents.

Description

Multiple issues were found in the teTeX 2 codebase that CSTeX builds upon (GLSA 200709-17, GLSA 200711-26). CSTeX also includes vulnerable code from the GD library (GLSA 200708-05), from Xpdf (GLSA 200709-12, GLSA 200711-22) and from T1Lib (GLSA 200710-12).

Impact

Remote attackers could possibly execute arbitrary code and local attackers could possibly overwrite arbitrary files with the privileges of the user running CSTeX via multiple vectors.

Workaround

There is no known workaround at this time.

Resolution

CSTeX is not maintained upstream, so the package was masked in Portage. We recommend that users unmerge CSTeX:

 # emerge --unmerge app-text/cstetex

As an alternative, users should upgrade their systems to use teTeX or TeX Live with its Babel packages.

References

Release Date
November 25, 2007

Latest Revision
November 25, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries