IRC Services: Denial of Service — GLSA 200712-12

A Denial of Service vulnerability has been reported in IRC Services.

Affected Packages

net-irc/ircservices on all architectures
Affected versions < 5.0.63
Unaffected versions >= 5.0.63

Background

IRC Services is a system of services to be used with Internet Relay Chat networks.

Description

loverboy reported that the "default_encrypt()" function in file encrypt.c does not properly handle overly long passwords.

Impact

A remote attacker could provide an overly long password to the vulnerable server, resulting in a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All IRC Services users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-irc/ircservices-5.0.63"

References

Release Date
December 13, 2007

Latest Revision
December 13, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries