PostgreSQL contains multiple vulnerabilities that could result in privilege escalation or a Denial of Service.
|Package||dev-db/postgresql on all architectures|
|Affected versions||< 8.0.15|
|Unaffected versions||>= 8.0.15, revision >= 7.4.19, revision >= 7.3.21|
PostgreSQL is an open source object-relational database management system.
If using the "expression indexes" feature, PostgreSQL executes index functions as the superuser during VACUUM and ANALYZE instead of the table owner, and allows SET ROLE and SET SESSION AUTHORIZATION in the index functions (CVE-2007-6600). Additionally, several errors involving regular expressions were found (CVE-2007-4769, CVE-2007-4772, CVE-2007-6067). Eventually, a privilege escalation vulnerability via unspecified vectors in the DBLink module was reported (CVE-2007-6601). This vulnerability is exploitable when local trust or ident authentication is used, and is due to an incomplete fix of CVE-2007-3278.
A remote authenticated attacker could send specially crafted queries containing complex regular expressions to the server that could result in a Denial of Service by a server crash (CVE-2007-4769), an infinite loop (CVE-2007-4772) or a memory exhaustion (CVE-2007-6067). The two other vulnerabilities can be exploited to gain additional privileges.
There is no known workaround for all these issues at this time.
All PostgreSQL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose "dev-db/postgresql"
January 29, 2008
January 29, 2008: 01