GOffice: Multiple vulnerabilities — GLSA 200801-19

Multiple vulnerabilities in GOffice could result in the execution of arbitrary code.

Affected Packages

x11-libs/goffice on all architectures
Affected versions < 0.6.1
Unaffected versions >= 0.6.1, revision >= 0.4.3

Background

GOffice is a library of document-centric objects and utilities based on GTK.

Description

GOffice includes a copy of PCRE which is vulnerable to multiple buffer overflows and memory corruptions vulnerabilities (GLSA 200711-30).

Impact

An attacker could entice a user to open specially crafted documents with GOffice, which could possibly lead to the execution of arbitrary code, a Denial of Service or the disclosure of sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All GOffice 0.4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/goffice-0.4.3"

All GOffice 0.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/goffice-0.6.1"

References

Release Date
January 30, 2008

Latest Revision
January 30, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries