Gallery: Multiple vulnerabilities — GLSA 200802-04

Multiple vulnerabilities were discovered in Gallery.

Affected Packages

www-apps/gallery on all architectures
Affected versions < 2.2.4
Unaffected versions >= 2.2.4, < 2.0

Background

Gallery is a web-based application for creating and viewing photo albums.

Description

The Gallery developement team reported and fixed critical vulnerabilities during an internal audit (CVE-2007-6685, CVE-2007-6686, CVE-2007-6687, CVE-2007-6688, CVE-2007-6689, CVE-2007-6690, CVE-2007-6691, CVE-2007-6692, CVE-2007-6693).

Impact

A remote attacker could exploit these vulnerabilities to execute arbitrary code, conduct Cross-Site Scripting and Cross-Site Request Forgery attacks, or disclose sensitive informations.

Workaround

There is no known workaround at this time.

Resolution

All Gallery users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/gallery-2.2.4"

References

Release Date
February 11, 2008

Latest Revision
February 11, 2008: 01

Severity
high

Exploitable
remote

Bugzilla entries