Multiple vulnerabilities in Firebird may allow the remote execution of arbitrary code.
|Package||dev-db/firebird on all architectures|
|Affected versions||< 18.104.22.16881.0-r5|
|Unaffected versions||>= 22.214.171.12481.0-r5|
Firebird is a multi-platform, open source relational database.
Firebird does not properly handle certain types of XDR requests, resulting in an integer overflow (CVE-2008-0387). Furthermore, it is vulnerable to a buffer overflow when processing usernames (CVE-2008-0467).
A remote attacker could send specially crafted XDR requests or an overly long username to the vulnerable server, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
There is no known workaround at this time.
All Firebird users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/firebird-126.96.36.19981.0-r5"
March 02, 2008
March 02, 2008: 01