Ghostscript: Buffer overflow — GLSA 200803-14

A stack-based buffer overflow has been discovered in Ghostscript, allowing arbitrary code execution.

Affected Packages

app-text/ghostscript-esp on all architectures
Affected versions < 8.15.4-r1
Unaffected versions >= 8.15.4-r1
app-text/ghostscript-gpl on all architectures
Affected versions < 8.61-r3
Unaffected versions >= 8.61-r3
app-text/ghostscript-gnu on all architectures
Affected versions < 8.60.0-r2
Unaffected versions >= 8.60.0-r2

Background

Ghostscript is a suite of software based on an interpreter for PostScript and PDF.

Description

Chris Evans (Google Security) discovered a stack-based buffer overflow within the zseticcspace() function in the file zicc.c when processing a PostScript file containing a long "Range" array in a .seticcscpate operator.

Impact

A remote attacker could exploit this vulnerability by enticing a user to open a specially crafted PostScript file, which could possibly lead to the execution of arbitrary code or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All Ghostscript ESP users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ghostscript-esp-8.15.4-r1"

All Ghostscript GPL users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gpl-8.61-r3"

All Ghostscript GNU users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gnu-8.60.0-r2"

References

Release Date
March 08, 2008

Latest Revision
March 08, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries