LIVE555 Media Server: Denial of Service — GLSA 200803-22

A Denial of Service vulnerability has been reported in LIVE555 Media Server.

Affected Packages

media-plugins/live on all architectures
Affected versions < 2008.02.08
Unaffected versions >= 2008.02.08

Background

LIVE555 Media Server is a set of libraries for multimedia streaming.

Description

Luigi Auriemma reported a signedness error in the parseRTSPRequestString() function when processing short RTSP queries.

Impact

A remote attacker could send a specially crafted RTSP query to the vulnerable server, resulting in a crash.

Workaround

There is no known workaround at this time.

Resolution

All LIVE555 Media Server users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-plugins/live-2008.02.08"

Note: Due to ABI changes, applications built against LIVE555 Media Server such as VLC or MPlayer should also be rebuilt.

References

Release Date
March 13, 2008

Latest Revision
March 13, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries