PCRE: Buffer overflow — GLSA 200803-24

A buffer overflow vulnerability has been discovered in PCRE, allowing for the execution of arbitrary code and Denial of Service.

Affected Packages

dev-libs/libpcre on all architectures
Affected versions < 7.6-r1
Unaffected versions >= 7.6-r1
dev-libs/glib on all architectures
Affected versions < 2.14.6
Unaffected versions >= 2.14.6, < 2.14.0

Background

PCRE is a Perl-compatible regular expression library. GLib includes a copy of PCRE.

Description

PCRE contains a buffer overflow vulnerability when processing a character class containing a very large number of characters with codepoints greater than 255.

Impact

A remote attacker could exploit this vulnerability by sending a specially crafted regular expression to an application making use of the PCRE library, which could possibly lead to the execution of arbitrary code or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All PCRE users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-7.6-r1"

All GLib users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.14.6"

References

Release Date
March 17, 2008

Latest Revision
March 17, 2008: 02

Severity
high

Exploitable
remote

Bugzilla entries