ssl-cert eclass: Certificate disclosure — GLSA 200803-30

An error in the usage of the ssl-cert eclass within multiple ebuilds might allow for disclosure of generated SSL private keys.

Affected Packages

app-admin/conserver on all architectures
Affected versions < 8.1.16
Unaffected versions >= 8.1.16
mail-mta/postfix on all architectures
Affected versions < 2.4.6-r2
Unaffected versions >= 2.4.6-r2, revision >= 2.3.8-r1, revision >= 2.2.11-r1
net-ftp/netkit-ftpd on all architectures
Affected versions < 0.17-r7
Unaffected versions >= 0.17-r7
net-im/ejabberd on all architectures
Affected versions < 1.1.3
Unaffected versions >= 1.1.3
net-irc/unrealircd on all architectures
Affected versions < 3.2.7-r2
Unaffected versions >= 3.2.7-r2
net-mail/cyrus-imapd on all architectures
Affected versions < 2.3.9-r1
Unaffected versions >= 2.3.9-r1
net-mail/dovecot on all architectures
Affected versions < 1.0.10
Unaffected versions >= 1.0.10
net-misc/stunnel on all architectures
Affected versions < 4.21-r1
Unaffected versions >= 4.21-r1, < 4.0
net-nntp/inn on all architectures
Affected versions < 2.4.3-r1
Unaffected versions >= 2.4.3-r1

Background

The ssl-cert eclass is a code module used by Gentoo ebuilds to generate SSL certificates.

Description

Robin Johnson reported that the docert() function provided by ssl-cert.eclass can be called by source building stages of an ebuild, such as src_compile() or src_install(), which will result in the generated SSL keys being included inside binary packages (binpkgs).

Impact

A local attacker could recover the SSL keys from publicly readable binary packages when "emerge" is called with the "--buildpkg (-b)" or "--buildpkgonly (-B)" option. Remote attackers can recover these keys if the packages are served to a network. Binary packages built using "quickpkg" are not affected.

Workaround

Do not use pre-generated SSL keys, but use keys that were generated using a different Certificate Authority.

Resolution

Upgrading to newer versions of the above packages will neither remove possibly compromised SSL certificates, nor old binary packages. Please remove the certificates installed by Portage, and then emerge an upgrade to the package.

All Conserver users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/conserver-8.1.16"

All Postfix 2.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-mta/postfix-2.4.6-r2"

All Postfix 2.3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-mta/postfix-2.3.8-r1"

All Postfix 2.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-mta/postfix-2.2.11-r1"

All Netkit FTP Server users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-ftp/netkit-ftpd-0.17-r7"

All ejabberd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-im/ejabberd-1.1.3"

All UnrealIRCd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-irc/unrealircd-3.2.7-r2"

All Cyrus IMAP Server users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-mail/cyrus-imapd-2.3.9-r1"

All Dovecot users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-mail/dovecot-1.0.10"

All stunnel 4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/stunnel-4.21"

All InterNetNews users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-nntp/inn-2.4.3-r1"

References

Release Date
March 20, 2008

Latest Revision
March 20, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries