JRockit: Multiple vulnerabilities — GLSA 200804-28

Multiple vulnerabilities have been identified in BEA JRockit.

Affected Packages

dev-java/jrockit-jdk-bin on all architectures
Affected versions < 1.5.0.14
Unaffected versions revision >= 1.4.2.16, >= 1.5.0.14

Background

JRockit is BEA WebLogic's J2SE Development Kit.

Description

Because of sharing the same codebase, JRockit is affected by the vulnerabilities mentioned in GLSA 200804-20.

Impact

A remote attacker could entice a user to run a specially crafted applet on a website or start an application in Java Web Start to execute arbitrary code outside of the Java sandbox and of the Java security restrictions with the privileges of the user running Java. The attacker could also obtain sensitive information, create, modify, rename and read local files, execute local applications, establish connections in the local network, bypass the same origin policy, and cause a Denial of Service via multiple vectors.

Workaround

There is no known workaround at this time.

Resolution

All JRockit 1.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/jrockit-jdk-bin-1.4.2.16"

All JRockit 1.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/jrockit-jdk-bin-1.5.0.14"

References

Release Date
April 24, 2008

Latest Revision
April 24, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries