KDE start_kdeinit: Multiple vulnerabilities — GLSA 200804-30

Multiple vulnerabilities in start_kdeinit could possibly allow a local attacker to execute arbitrary code with root privileges.

Affected Packages

kde-base/kdelibs on all architectures
Affected versions < 4.0
Unaffected versions revision >= 3.5.8-r4, revision >= 3.5.9-r3, > 4.0, < 3.5.5, revision >= 3.5.10-r2

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like operating systems. start_kdeinit is a wrapper for kdeinit.

Description

Vulnerabilities have been reported in the processing of user-controlled data by start_kdeinit, which is setuid root by default.

Impact

A local attacker could possibly execute arbitrary code with root privileges, cause a Denial of Service or send Unix signals to other processes, when start_kdeinit is setuid root.

Workaround

There is no known workaround at this time.

Resolution

All kdelibs users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=kde-base/kdelibs-3.5.8-r4"

References

Release Date
April 29, 2008

Latest Revision
April 08, 2009: 02

Severity
high

Exploitable
local

Bugzilla entries