phpMyAdmin: Information disclosure — GLSA 200805-02

A vulnerability in phpMyAdmin may lead to information disclosure.

Affected Packages

dev-db/phpmyadmin on all architectures
Affected versions < 2.11.5.2
Unaffected versions >= 2.11.5.2

Background

phpMyAdmin is a tool written in PHP intended to handle the administration of MySQL databases from a web-browser.

Description

Cezary Tomczak reported that an undefined UploadDir variable exposes an information disclosure vulnerability when running on shared hosts.

Impact

A remote attacker with CREATE TABLE permissions can exploit this vulnerability via a specially crafted HTTP POST request in order to read arbitrary files.

Workaround

There is no known workaround at this time.

Resolution

All phpMyAdmin users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-2.11.5.2"

References

Release Date
May 05, 2008

Latest Revision
May 05, 2008: 01

Severity
low

Exploitable
remote

Bugzilla entries