PTeX: Multiple vulnerabilities — GLSA 200805-13

Multiple vulnerabilities were discovered in PTeX, possibly allowing the execution of arbitrary code or overwriting arbitrary files.

Affected Packages

app-text/ptex on all architectures
Affected versions < 3.1.10_p20071203
Unaffected versions >= 3.1.10_p20071203

Background

PTeX is a TeX distribution with Japanese support. It is used for creating and manipulating LaTeX documents.

Description

Multiple issues were found in the teTeX 2 codebase that PTeX builds upon (GLSA 200709-17, GLSA 200711-26). PTeX also includes vulnerable code from the GD library (GLSA 200708-05), from Xpdf (GLSA 200709-12, GLSA 200711-22) and from T1Lib (GLSA 200710-12).

Impact

Remote attackers could possibly execute arbitrary code and local attackers could possibly overwrite arbitrary files with the privileges of the user running PTeX via multiple vectors, e.g. enticing users to open specially crafted files.

Workaround

There is no known workaround at this time.

Resolution

All PTeX users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ptex-3.1.10_p20071203"

References

Release Date
May 12, 2008

Latest Revision
May 12, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries