GnuTLS: Execution of arbitrary code — GLSA 200805-20

Multiple vulnerabilities might allow for the execution of arbitrary code in daemons using GnuTLS.

Affected Packages

net-libs/gnutls on all architectures
Affected versions < 2.2.5
Unaffected versions >= 2.2.5

Background

GnuTLS is an implementation of Secure Sockets Layer (SSL) 3.0 and Transport Layer Security (TLS) 1.0, 1.1 and 1.2.

Description

Ossi Herrala and Jukka Taimisto of Codenomicon reported three vulnerabilities in libgnutls of GnuTLS:

  • "Client Hello" messages containing an invalid server name can lead to a buffer overflow when evaluating "Security Parameters" (CVE-2008-1948).
  • Multiple "Client Hello" messages can lead to a NULL pointer dereference (CVE-2008-1949).
  • A TLS handshake including an encrypted "Client Hello" message and an invalid record length could lead to a buffer overread (CVE-2008-1950).

Impact

Unauthenticated remote attackers could exploit these vulnerabilities to cause Denial of Service conditions in daemons using GnuTLS. The first vulnerability (CVE-2008-1948) might allow for the execution of arbitrary code with the privileges of the daemon handling incoming TLS connections.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.2.5"

References

Release Date
May 21, 2008

Latest Revision
May 21, 2008: 01

Severity
high

Exploitable
remote

Bugzilla entries