libvorbis: Multiple vulnerabilities — GLSA 200806-09

Multiple vulnerabilities in libvorbis might lead to the execution of arbitrary code.

Affected Packages

media-libs/libvorbis on all architectures
Affected versions < 1.2.1_rc1
Unaffected versions >= 1.2.1_rc1

Background

libvorbis is the reference implementation of the Xiph.org Ogg Vorbis audio file format. It is used by many applications for playback of Ogg Vorbis files.

Description

Will Drewry of the Google Security Team reported multiple vulnerabilities in libvorbis:

  • A zero value for "codebook.dim" is not properly handled, leading to a crash, infinite loop or triggering an integer overflow (CVE-2008-1419).
  • An integer overflow in "residue partition value" evaluation might lead to a heap-based buffer overflow (CVE-2008-1420).
  • An integer overflow in a certain "quantvals" and "quantlist" calculation might lead to a heap-based buffer overflow (CVE-2008-1423).

Impact

A remote attacker could exploit these vulnerabilities by enticing a user to open a specially crafted Ogg Vorbis file or network stream with an application using libvorbis. This might lead to the execution of arbitrary code with the privileges of the user playing the file or a Denial of Service by a crash or CPU consumption.

Workaround

There is no known workaround at this time.

Resolution

All libvorbis users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libvorbis-1.2.1_rc1"

References

Release Date
June 23, 2008

Latest Revision
June 23, 2008: 02

Severity
normal

Exploitable
remote

Bugzilla entries