Multiple integer overflows may allow for Denial of Service.
|Package||dev-lang/python on all architectures|
|Affected versions||< 2.4.4-r13|
|Unaffected versions||revision >= 2.3.6-r6, >= 2.4.4-r13|
Python is an interpreted, interactive, object-oriented programming language.
Multiple vulnerabilities were discovered in Python:
A remote attacker could exploit these vulnerabilities to cause a Denial of Service or possibly the remote execution of arbitrary code with the privileges of the user running Python.
There is no known workaround at this time.
The imageop module is no longer built in the unaffected versions.
All Python 2.3 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-2.3.6-r6"
All Python 2.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-2.4.4-r13"