PCRE: Buffer overflow — GLSA 200807-03

A buffer overflow vulnerability has been discovered in PCRE, allowing for the execution of arbitrary code and a Denial of Service.

Affected Packages

dev-libs/libpcre on all architectures
Affected versions < 7.7-r1
Unaffected versions >= 7.7-r1
dev-libs/glib on all architectures
Affected versions < 2.16.3-r1
Unaffected versions >= 2.16.3-r1, < 2.14.0

Background

PCRE is a Perl-compatible regular expression library. GLib includes a copy of PCRE.

Description

Tavis Ormandy of the Google Security team reported a heap-based buffer overflow when compiling regular expression patterns containing "Internal Option Settings" such as "(?i)".

Impact

A remote attacker could exploit this vulnerability by sending a specially crafted regular expression to an application making use of the PCRE library, which could possibly lead to the execution of arbitrary code or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All PCRE users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-7.7-r1"

All GLib users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.16.3-r1"

References

Release Date
July 07, 2008

Latest Revision
July 07, 2008: 01

Severity
high

Exploitable
remote

Bugzilla entries