Postfix: Denial of Service — GLSA 200809-09

A memory leak in Postfix might allow local users to cause a Denial of Service.

Affected Packages

mail-mta/postfix on all architectures
Affected versions < 2.4.9, < 2.5.5
Unaffected versions >= 2.4.9, >= 2.5.5

Background

Postfix is Wietse Venema's mailer that attempts to be fast, easy to administer, and secure, as an alternative to the widely-used Sendmail program.

Description

It has been discovered than Postfix leaks an epoll file descriptor when executing external commands, e.g. user-controlled $HOME/.forward or $HOME/.procmailrc files. NOTE: This vulnerability only concerns Postfix instances running on Linux 2.6 kernels.

Impact

A local attacker could exploit this vulnerability to reduce the performance of Postfix, and possibly trigger an assertion, resulting in a Denial of Service.

Workaround

Allow only trusted users to control delivery to non-Postfix commands.

Resolution

All Postfix 2.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-mta/postfix-2.4.9"

All Postfix 2.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-mta/postfix-2.5.5"

References

Release Date
September 19, 2008

Latest Revision
September 19, 2008: 01

Severity
normal

Exploitable
local

Bugzilla entries