Multiple buffer overflow vulnerabilities have been discovered in Git.
|Package||dev-util/git on all architectures|
|Affected versions||< 188.8.131.52|
|Unaffected versions||>= 184.108.40.206|
Git is a distributed version control system.
Multiple boundary errors in the functions diff_addremove() and diff_change() when processing overly long repository path names were reported.
A remote attacker could entice a user to run commands like "git-diff" or "git-grep" on a specially crafted repository, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
There is no known workaround at this time.
All Git users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-util/git-220.127.116.11"
September 25, 2008
September 25, 2008: 01