IPsec-Tools: racoon Denial of Service — GLSA 200812-03

IPsec-Tools' racoon is affected by a remote Denial of Service vulnerability.

Affected Packages

net-firewall/ipsec-tools on all architectures
Affected versions < 0.7.1
Unaffected versions >= 0.7.1

Background

IPsec-Tools is a port of KAME's implementation of the IPsec utilities. It contains a collection of network monitoring tools, including racoon, ping, and ping6.

Description

Two Denial of Service vulnerabilities have been reported in racoon:

  • The vendor reported a memory leak in racoon/proposal.c that can be triggered via invalid proposals (CVE-2008-3651).
  • Krzysztof Piotr Oledzk reported that src/racoon/handler.c does not remove an "orphaned ph1" (phase 1) handle when it has been initiated remotely (CVE-2008-3652).

Impact

An attacker could exploit these vulnerabilities to cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All IPsec-Tools users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-firewall/ipsec-tools-0.7.1"

References

Release Date
December 02, 2008

Latest Revision
December 02, 2008: 01

Severity
normal

Exploitable
remote

Bugzilla entries