OpenSC: Insufficient protection of smart card PIN — GLSA 200812-09

Smart cards formatted using OpenSC do not sufficiently protect the PIN, allowing attackers to reset it.

Affected Packages

dev-libs/opensc on all architectures
Affected versions < 0.11.6
Unaffected versions >= 0.11.6

Background

OpenSC is a smart card application that allows reading and writing via PKCS#11.

Description

Chaskiel M Grundman reported that OpenSC uses weak permissions (ADMIN file control information of 00) for the 5015 directory on smart cards and USB crypto tokens running Siemens CardOS M4.

Impact

A physically proximate attacker can exploit this vulnerability to change the PIN on a smart card and use it for authentication, leading to privilege escalation.

Workaround

There is no known workaround at this time.

Resolution

All OpenSC users should upgrade to the latest version, and then check and update their smart cards:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/opensc-0.11.6"
 # pkcs15-tool --test-update
 # pkcs15-tool --test-update --update

References

Release Date
December 10, 2008

Latest Revision
December 10, 2008: 01

Severity
normal

Exploitable
local

Bugzilla entries