GnuTLS: Certificate validation error — GLSA 200901-10

A certificate validation error in GnuTLS might allow for spoofing attacks.

Affected Packages

net-libs/gnutls on all architectures
Affected versions < 2.4.1-r2
Unaffected versions >= 2.4.1-r2

Background

GnuTLS is an open-source implementation of TLS 1.0 and SSL 3.0.

Description

Martin von Gagern reported that the _gnutls_x509_verify_certificate() function in lib/x509/verify.c trusts certificate chains in which the last certificate is an arbitrary trusted, self-signed certificate.

Impact

A remote attacker could exploit this vulnerability and spoof arbitrary names to conduct Man-In-The-Middle attacks and intercept sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.4.1-r2"

References

Release Date
January 14, 2009

Latest Revision
January 14, 2009: 01

Severity
normal

Exploitable
remote

Bugzilla entries