FFmpeg: Multiple vulnerabilities — GLSA 200903-33

Multiple vulnerabilities in FFmpeg may lead to the remote execution of arbitrary code or a Denial of Service.

Affected Packages

media-video/ffmpeg on all architectures
Affected versions < 0.4.9_p20090201
Unaffected versions >= 0.4.9_p20090201
media-plugins/gst-plugins-ffmpeg on all architectures
Affected versions < 0.10.5
Unaffected versions >= 0.10.5
media-video/mplayer on all architectures
Affected versions < 1.0_rc2_p28450
Unaffected versions >= 1.0_rc2_p28450

Background

FFmpeg is a complete solution to record, convert and stream audio and video. gst-plugins-ffmpeg is a FFmpeg based gstreamer plugin which includes a vulnerable copy of FFmpeg code. Mplayer is a multimedia player which also includes a vulnerable copy of the code.

Description

Multiple vulnerabilities were found in FFmpeg:

  • astrange reported a stack-based buffer overflow in the str_read_packet() in libavformat/psxstr.c when processing .str files (CVE-2008-3162).
  • Multiple buffer overflows in libavformat/utils.c (CVE-2008-4866).
  • A buffer overflow in libavcodec/dca.c (CVE-2008-4867).
  • An unspecified vulnerability in the avcodec_close() function in libavcodec/utils.c (CVE-2008-4868).
  • Unspecified memory leaks (CVE-2008-4869).
  • Tobias Klein repoerted a NULL pointer dereference due to an integer signedness error in the fourxm_read_header() function in libavformat/4xm.c (CVE-2009-0385).

Impact

A remote attacker could entice a user to open a specially crafted media file, possibly leading to the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All FFmpeg users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-video/ffmpeg-0.4.9_p20090201"

All gst-plugins-ffmpeg users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-plugins/gst-plugins-ffmpeg-0.10.5"

All Mplayer users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-video/mplayer-1.0_rc2_p28450"

References

Release Date
March 19, 2009

Latest Revision
March 19, 2009: 01

Severity
normal

Exploitable
remote

Bugzilla entries