Ghostscript: User-assisted execution of arbitrary code — GLSA 200903-37

Multiple integer overflows in the Ghostscript ICC library might allow for user-assisted execution of arbitrary code.

Affected Packages

app-text/ghostscript-gpl on all architectures
Affected versions < 8.64-r2
Unaffected versions >= 8.64-r2
app-text/ghostscript-gnu on all architectures
Affected versions < 8.62.0
Unaffected versions >= 8.62.0
app-text/ghostscript-esp on all architectures
Affected versions <= 8.15.4-r1
Unaffected versions

Background

Ghostscript is an interpreter for the PostScript language and the Portable Document Format (PDF).

Description

Jan Lieskovsky from the Red Hat Security Response Team discovered the following vulnerabilities in Ghostscript's ICC Library:

  • Multiple integer overflows (CVE-2009-0583).
  • Multiple insufficient bounds checks on certain variable sizes (CVE-2009-0584).

Impact

A remote attacker could entice a user to open a specially crafted PostScript file containing images and a malicious ICC profile, possibly resulting in the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All GPL Ghostscript users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gpl-8.64-r2"

All GNU Ghostscript users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/ghostscript-gnu-8.62.0"

We recommend that users unmerge ESP Ghostscript and use GPL or GNU Ghostscript instead:

 # emerge --unmerge "app-text/ghostscript-esp"

For installation instructions, see above.

References

Release Date
March 23, 2009

Latest Revision
March 23, 2009: 01

Severity
normal

Exploitable
remote

Bugzilla entries