gedit: Untrusted search path — GLSA 200903-41

A vulnerability in gedit might allow local attackers to execute arbitrary code.

Affected Packages

app-editors/gedit on all architectures
Affected versions < 2.24.3
Unaffected versions revision >= 2.22.3-r1, >= 2.24.3

Background

gedit is a text editor for the GNOME desktop.

Description

James Vega reported that gedit uses the current working directory when searching for python modules, a vulnerability related to CVE-2008-5983.

Impact

A local attacker could entice a user to open gedit from a specially crafted environment, possibly resulting in the execution of arbitrary code with the privileges of the user running the application.

Workaround

Do not run gedit from untrusted working directories.

Resolution

All gedit 2.22.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-editors/gedit-2.22.3-r1"

All gedit 2.24.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-editors/gedit-2.24.3"

References

Release Date
March 30, 2009

Latest Revision
March 30, 2009: 01

Severity
normal

Exploitable
local

Bugzilla entries