Multiple vulnerabilities in GnuTLS might result in a Denial of Service, spoofing or the generation of invalid keys.
|Package||net-libs/gnutls on all architectures|
|Affected versions||< 2.6.6|
|Unaffected versions||>= 2.6.6|
GnuTLS is an Open Source implementation of the TLS 1.0 and SSL 3.0 protocols.
The following vulnerabilities were found in GnuTLS:
A remote attacker could entice a user or automated system to process a specially crafted DSA certificate, possibly resulting in a Denial of Service condition. NOTE: This issue might have other unspecified impact including the execution of arbitrary code. Furthermore, a remote attacker could spoof signatures on certificates and the "gnutls-cli" application can be tricked into accepting an invalid certificate.
There is no known workaround at this time.
All GnuTLS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.6.6"
May 24, 2009
May 24, 2009: 01