Multiple errors in phpMyAdmin might allow the remote execution of arbitrary code or a Cross-Site Scripting attack.
|Package||dev-db/phpmyadmin on all architectures|
|Affected versions||< 184.108.40.206|
|Unaffected versions||>= 220.127.116.11|
phpMyAdmin is a web-based management tool for MySQL databases.
Multiple vulnerabilities have been reported in phpMyAdmin:
A remote unauthorized attacker could exploit the first vulnerability to execute arbitrary code with the privileges of the user running phpMyAdmin and conduct Cross-Site Scripting attacks using the second vulnerability.
Removing the "scripts/setup.php" file protects you from CVE-2009-1151.
All phpMyAdmin users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-18.104.22.168"
June 29, 2009
June 29, 2009: 01