Horde: Multiple vulnerabilities — GLSA 200909-14

Multiple vulnerabilities have been discovered in Horde and two modules, allowing for the execution of arbitrary code, information disclosure, or Cross-Site Scripting.

Affected Packages

www-apps/horde on all architectures
Affected versions < 3.3.4
Unaffected versions >= 3.3.4
www-apps/horde-imp on all architectures
Affected versions < 4.3.4
Unaffected versions >= 4.3.4
www-apps/horde-passwd on all architectures
Affected versions < 3.1.1
Unaffected versions >= 3.1.1

Background

Horde is a web application framework written in PHP. Horde IMP, the "Internet Messaging Program", is a Webmail module and Horde Passwd is a password changing module for Horde.

Description

Multiple vulnerabilities have been discovered in Horde:

  • Gunnar Wrobel reported an input sanitation and directory traversal flaw in framework/Image/Image.php, related to the "Horde_Image driver name" (CVE-2009-0932).
  • Gunnar Wrobel reported that data sent to horde/services/portal/cloud_search.php is not properly sanitized before used in the output (CVE-2009-0931).
  • It was reported that data sent to framework/Text_Filter/Filter/xss.php is not properly sanitized before used in the output (CVE-2008-5917).

Horde Passwd: David Wharton reported that data sent via the "backend" parameter to passwd/main.php is not properly sanitized before used in the output (CVE-2009-2360).

Horde IMP: Gunnar Wrobel reported that data sent to smime.php, pgp.php, and message.php is not properly sanitized before used in the output (CVE-2009-0930).

Impact

A remote authenticated attacker could exploit these vulnerabilities to execute arbitrary PHP files on the server, or disclose the content of arbitrary files, both only if the file is readable to the web server. A remote authenticated attacker could conduct Cross-Site Scripting attacks. NOTE: Some Cross-Site Scripting vectors are limited to the usage of Microsoft Internet Explorer.

Workaround

There is no known workaround at this time.

Resolution

All Horde users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-3.3.4"

All Horde IMP users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-imp-4.3.4"

All Horde Passwd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-passwd-3.1.1"

References

Release Date
September 12, 2009

Latest Revision
September 12, 2009: 01

Severity
normal

Exploitable
remote

Bugzilla entries