nginx: Remote execution of arbitrary code — GLSA 200909-18

A buffer underflow vulnerability in the request URI processing of nginx might enable remote attackers to execute arbitrary code or cause a Denial of Service.

Affected Packages

www-servers/nginx on all architectures
Affected versions < 0.7.62
Unaffected versions revision >= 0.5.38, revision >= 0.6.39, >= 0.7.62

Background

nginx is a robust, small and high performance HTTP and reverse proxy server.

Description

Chris Ries reported a heap-based buffer underflow in the ngx_http_parse_complex_uri() function in http/ngx_http_parse.c when parsing the request URI.

Impact

A remote attacker might send a specially crafted request URI to a nginx server, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the server, or a Denial of Service. NOTE: By default, nginx runs as the "nginx" user.

Workaround

There is no known workaround at this time.

Resolution

All nginx 0.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/nginx-0.5.38"

All nginx 0.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/nginx-0.6.39"

All nginx 0.7.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/nginx-0.7.62"

References

Release Date
September 18, 2009

Latest Revision
September 18, 2009: 01

Severity
high

Exploitable
remote

Bugzilla entries