Sun JDK/JRE: Multiple vulnerabilities — GLSA 200911-02

Multiple vulnerabilities in the Sun JDK and JRE allow for several attacks, including the remote execution of arbitrary code.

Affected Packages

dev-java/sun-jre-bin on all architectures
Affected versions < 1.6.0.17
Unaffected versions revision >= 1.5.0.22, >= 1.6.0.17
dev-java/sun-jdk on all architectures
Affected versions < 1.6.0.17
Unaffected versions revision >= 1.5.0.22, >= 1.6.0.17
dev-java/blackdown-jre on all architectures
Affected versions <= 1.4.2.03-r14
Unaffected versions
dev-java/blackdown-jdk on all architectures
Affected versions <= 1.4.2.03-r16
Unaffected versions
app-emulation/emul-linux-x86-java on all architectures
Affected versions < 1.6.0.17
Unaffected versions revision >= 1.5.0.22, >= 1.6.0.17

Background

The Sun Java Development Kit (JDK) and the Sun Java Runtime Environment (JRE) provide the Sun Java platform.

Description

Multiple vulnerabilities have been reported in the Sun Java implementation. Please review the CVE identifiers referenced below and the associated Sun Alerts for details.

Impact

A remote attacker could entice a user to open a specially crafted JAR archive, applet, or Java Web Start application, possibly resulting in the execution of arbitrary code with the privileges of the user running the application. Furthermore, a remote attacker could cause a Denial of Service affecting multiple services via several vectors, disclose information and memory contents, write or execute local files, conduct session hijacking attacks via GIFAR files, steal cookies, bypass the same-origin policy, load untrusted JAR files, establish network connections to arbitrary hosts and posts via several vectors, modify the list of supported graphics configurations, bypass HMAC-based authentication systems, escalate privileges via several vectors and cause applet code to be executed with older, possibly vulnerable versions of the JRE.

NOTE: Some vulnerabilities require a trusted environment, user interaction, a DNS Man-in-the-Middle or Cross-Site-Scripting attack.

Workaround

There is no known workaround at this time.

Resolution

All Sun JRE 1.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.5.0.22"

All Sun JRE 1.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.6.0.17"

All Sun JDK 1.5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.5.0.22"

All Sun JDK 1.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.6.0.17"

All users of the precompiled 32bit Sun JRE 1.5.x should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/emul-linux-x86-java-1.5.0.22"

All users of the precompiled 32bit Sun JRE 1.6.x should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/emul-linux-x86-java-1.6.0.17"

All Sun JRE 1.4.x, Sun JDK 1.4.x, Blackdown JRE, Blackdown JDK and precompiled 32bit Sun JRE 1.4.x users are strongly advised to unmerge Java 1.4:

 # emerge --unmerge =app-emulation/emul-linux-x86-java-1.4*
 # emerge --unmerge =dev-java/sun-jre-bin-1.4*
 # emerge --unmerge =dev-java/sun-jdk-1.4*
 # emerge --unmerge dev-java/blackdown-jdk
 # emerge --unmerge dev-java/blackdown-jre

Gentoo is ceasing support for the 1.4 generation of the Sun Java Platform in accordance with upstream. All 1.4 JRE and JDK versions are masked and will be removed shortly.

References

Release Date
November 17, 2009

Latest Revision
November 17, 2009: 01

Severity
normal

Exploitable
remote

Bugzilla entries