Oracle JRE/JDK: Multiple vulnerabilities — GLSA 201006-18

The Oracle JDK and JRE are vulnerable to multiple unspecified vulnerabilities.

Affected Packages

dev-java/sun-jre-bin on all architectures
Affected versions < 1.6.0.20
Unaffected versions >= 1.6.0.20
dev-java/sun-jdk on all architectures
Affected versions < 1.6.0.20
Unaffected versions >= 1.6.0.20
app-emulation/emul-linux-x86-java on all architectures
Affected versions < 1.6.0.20
Unaffected versions >= 1.6.0.20

Background

The Oracle Java Development Kit (JDK) (formerly known as Sun JDK) and the Oracle Java Runtime Environment (JRE) (formerly known as Sun JRE) provide the Oracle Java platform (formerly known as Sun Java Platform).

Description

Multiple vulnerabilities have been reported in the Oracle Java implementation. Please review the CVE identifiers referenced below and the associated Oracle Critical Patch Update Advisory for details.

Impact

A remote attacker could exploit these vulnerabilities to cause unspecified impact, possibly including remote execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All Oracle JRE 1.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.6.0.20"

All Oracle JDK 1.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.6.0.20"

All users of the precompiled 32bit Oracle JRE 1.6.x should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/emul-linux-x86-java-1.6.0.20"

All Oracle JRE 1.5.x, Oracle JDK 1.5.x, and precompiled 32bit Oracle JRE 1.5.x users are strongly advised to unmerge Java 1.5:

 # emerge --unmerge =app-emulation/emul-linux-x86-java-1.5*
 # emerge --unmerge =dev-java/sun-jre-bin-1.5*
 # emerge --unmerge =dev-java/sun-jdk-1.5*

Gentoo is ceasing support for the 1.5 generation of the Oracle Java Platform in accordance with upstream. All 1.5 JRE versions are masked and will be removed shortly. All 1.5 JDK versions are marked as "build-only" and will be masked for removal shortly. Users are advised to change their default user and system Java implementation to an unaffected version. For example:

 # java-config --set-system-vm sun-jdk-1.6

For more information, please consult the Gentoo Linux Java documentation.

References

Release Date
June 04, 2010

Latest Revision
June 04, 2010: 01

Severity
normal

Exploitable
remote

Bugzilla entries