wxGTK: User-assisted execution of arbitrary code — GLSA 201009-01

An integer overflow vulnerability in wxGTK might enable remote attackers to cause the execution of arbitrary code.

Affected Packages

x11-libs/wxGTK on all architectures
Affected versions < 2.8.10.1-r1
Unaffected versions revision >= 2.6.4.0-r5
>= 2.8.10.1-r1

Background

wxGTK is the GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit.

Description

wxGTK is prone to an integer overflow error in the wxImage::Create() function in src/common/image.cpp, possibly leading to a heap-based buffer overflow.

Impact

A remote attacker might entice a user to open a specially crafted JPEG file using a program that uses wxGTK, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All wxGTK 2.6 users should upgrade to an updated version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/wxGTK-2.6.4.0-r5"

All wxGTK 2.8 users should upgrade to an updated version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/wxGTK-2.8.10.1-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are available since August 9, 2009. It is likely that your system is already no longer affected by this issue.

References

Release Date
September 02, 2010

Latest Revision
September 02, 2010: 01

Severity
normal

Exploitable
remote

Bugzilla entries