Libpng: Multiple vulnerabilities — GLSA 201010-01

Multiple vulnerabilities in libpng might lead to privilege escalation or a Denial of Service.

Affected Packages

media-libs/libpng on all architectures
Affected versions < 1.4.3
Unaffected versions >= 1.4.3
>= 1.2.46

Background

libpng is a standard library used to process PNG (Portable Network Graphics) images. It is used by several programs, including web browsers and potentially server processes.

Description

Multiple vulnerabilities were found in libpng:

  • The png_decompress_chunk() function in pngrutil.c does not properly handle certain type of compressed data (CVE-2010-0205)
  • A buffer overflow in pngread.c when using progressive applications (CVE-2010-1205)
  • A memory leak in pngrutil.c when dealing with a certain type of chunks (CVE-2010-2249)

Impact

An attacker could exploit these vulnerabilities to cause programs linked against the library to crash or execute arbitrary code with the permissions of the user running the vulnerable program, which could be the root user.

Workaround

There is no known workaround at this time.

Resolution

All libpng 1.4 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.4.3"
 

All libpng 1.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.46"
 

References

Release Date
October 05, 2010

Latest Revision
January 03, 2017: 9

Severity
normal

Exploitable
remote

Bugzilla entries