Multiple vulnerabilities in libpng might lead to privilege escalation or a Denial of Service.
|Package||media-libs/libpng on all architectures|
|Affected versions||< 1.4.3|
|Unaffected versions||>= 1.4.3
libpng is a standard library used to process PNG (Portable Network Graphics) images. It is used by several programs, including web browsers and potentially server processes.
Multiple vulnerabilities were found in libpng:
An attacker could exploit these vulnerabilities to cause programs linked against the library to crash or execute arbitrary code with the permissions of the user running the vulnerable program, which could be the root user.
There is no known workaround at this time.
All libpng 1.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.4.3"
All libpng 1.2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.46"