GnuTLS: Multiple vulnerabilities — GLSA 201110-05

Multiple vulnerabilities were found in GnuTLS, allowing for easier man-in-the-middle attacks.

Affected Packages

net-libs/gnutls on all architectures
Affected versions < 2.10.0
Unaffected versions >= 2.10.0

Background

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.

Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers referenced below for details.

Impact

An attacker could perform man-in-the-middle attacks to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority or to inject an arbitrary amount of chosen plaintext into the beginning of the application protocol stream, allowing for further exploitation.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.10.0"
 

NOTE: This is a legacy GLSA. Updates for all affected architectures are available since August 6, 2010. It is likely that your system is already no longer affected by this issue.

References

Release Date
October 10, 2011

Latest Revision
October 10, 2011: 1

Severity
normal

Exploitable
remote

Bugzilla entries