Conky: Privilege escalation — GLSA 201110-09

A privilege escalation vulnerability was found in Conky.

Affected Packages

app-admin/conky on all architectures
Affected versions < 1.8.1-r2
Unaffected versions >= 1.8.1-r2

Background

Conky is an advanced, highly configurable system monitor for X.

Description

A privilege escalation vulnerability due to an insecure temporary file was found in Conky.

Impact

A local attacker could possibly overwrite arbitrary files with the privileges of the user running Conky.

Workaround

There is no known workaround at this time.

Resolution

All Conky users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-admin/conky-1.8.1-r2"
 

References

Release Date
October 13, 2011

Latest Revision
October 13, 2011: 1

Severity
normal

Exploitable
local

Bugzilla entries