Unbound: Denial of Service — GLSA 201110-12

Multiple Denial of Service vulnerabilities were found in Unbound.

Affected Packages

net-dns/unbound on all architectures
Affected versions < 1.4.10
Unaffected versions >= 1.4.10

Background

Unbound is a validating, recursive, and caching DNS resolver.

Description

Multiple vulnerabilities have been discovered in unbound. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All Unbound users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dns/unbound-1.4.10"
 

References

Release Date
October 15, 2011

Latest Revision
October 15, 2011: 1

Severity
normal

Exploitable
remote

Bugzilla entries