D-Bus: Multiple vulnerabilities — GLSA 201110-14

Multiple vulnerabilities were found in D-Bus, the worst of which allowing for a symlink attack.

Affected Packages

sys-apps/dbus on all architectures
Affected versions < 1.4.12
Unaffected versions >= 1.4.12

Background

D-Bus is a message bus system, a simple way for applications to talk to each other.

Description

Multiple vulnerabilities have been discovered in D-Bus. Please review the CVE identifiers referenced below for details.

Impact

The vulnerabilities allow for local Denial of Service (daemon crash), or arbitrary file overwriting.

Workaround

There is no known workaround at this time.

Resolution

All D-Bus users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-apps/dbus-1.4.12"
 

References

Release Date
October 21, 2011

Latest Revision
October 21, 2011: 1

Severity
normal

Exploitable
local

Bugzilla entries