Asterisk: Multiple vulnerabilities — GLSA 201110-21

Multiple vulnerabilities in Asterisk might allow unauthenticated remote attackers to execute arbitrary code.

Affected Packages

net-misc/asterisk on all architectures
Affected versions < 1.8.7.1
Unaffected versions >= 1.8.7.1
revision >= 1.6.2.18.2

Background

Asterisk is an open source telephony engine and toolkit.

Description

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers referenced below for details.

Impact

An unauthenticated remote attacker may execute code with the privileges of the Asterisk process or cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All asterisk 1.6.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.6.2.18.2"
 

All asterisk 1.8.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.7.1"
 

References

Release Date
October 24, 2011

Latest Revision
October 24, 2011: 1

Severity
high

Exploitable
remote

Bugzilla entries