PostgreSQL: Multiple vulnerabilities — GLSA 201110-22

Multiple vulnerabilities in the PostgreSQL server and client allow remote attacker to conduct several attacks, including the execution of arbitrary code and Denial of Service.

Affected Packages

dev-db/postgresql on all architectures
Affected versions <= 9
Unaffected versions
dev-db/postgresql-server on all architectures
Affected versions < 9.0.5
Unaffected versions >= 9.0.5
revision >= 8.4.9
revision >= 8.3.16
revision >= 8.2.22
revision >= 8.4.10
revision >= 8.3.17
revision >= 8.2.23
>= 8.4.11
>= 8.3.18
dev-db/postgresql-base on all architectures
Affected versions < 9.0.5
Unaffected versions >= 9.0.5
revision >= 8.4.9
revision >= 8.3.16
revision >= 8.2.22
revision >= 8.4.10
revision >= 8.3.17
revision >= 8.2.23
>= 8.4.11
>= 8.3.18

Background

PostgreSQL is an open source object-relational database management system.

Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please review the CVE identifiers referenced below for details.

Impact

A remote authenticated attacker could send a specially crafted SQL query to a PostgreSQL server with the "intarray" module enabled, possibly resulting in the execution of arbitrary code with the privileges of the PostgreSQL server process, or a Denial of Service condition. Furthermore, a remote authenticated attacker could execute arbitrary Perl code, cause a Denial of Service condition via different vectors, bypass LDAP authentication, bypass X.509 certificate validation, gain database privileges, exploit weak blowfish encryption and possibly cause other unspecified impact.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 8.2 users should upgrade to the latest 8.2 base version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-base-8.2.22:8.2"
 

All PostgreSQL 8.3 users should upgrade to the latest 8.3 base version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-base-8.3.16:8.3"
 

All PostgreSQL 8.4 users should upgrade to the latest 8.4 base version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-base-8.4.9:8.4"
 

All PostgreSQL 9.0 users should upgrade to the latest 9.0 base version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-base-9.0.5:9.0"
 

All PostgreSQL 8.2 server users should upgrade to the latest 8.2 server version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-server-8.2.22:8.2"
 

All PostgreSQL 8.3 server users should upgrade to the latest 8.3 server version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-server-8.3.16:8.3"
 

All PostgreSQL 8.4 server users should upgrade to the latest 8.4 server version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-server-8.4.9:8.4"
 

All PostgreSQL 9.0 server users should upgrade to the latest 9.0 server version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-db/postgresql-server-9.0.5:9.0"
 

The old unsplit PostgreSQL packages have been removed from portage. Users still using them are urged to migrate to the new PostgreSQL packages as stated above and to remove the old package:

 # emerge --unmerge "dev-db/postgresql"
 

References

Release Date
October 25, 2011

Latest Revision
March 05, 2012: 3

Severity
normal

Exploitable
remote

Bugzilla entries