Chromium, V8: Multiple vulnerabilities — GLSA 201111-01

Multiple vulnerabilities have been reported in Chromium and V8, some of which may allow execution of arbitrary code and local root privilege escalation.

Affected Packages

www-client/chromium on all architectures
Affected versions < 15.0.874.102
Unaffected versions >= 15.0.874.102
dev-lang/v8 on all architectures
Affected versions < 3.5.10.22
Unaffected versions >= 3.5.10.22

Background

Chromium is an open-source web browser project. V8 is Google's open source JavaScript engine.

Description

Multiple vulnerabilities have been discovered in Chromium and V8. Please review the CVE identifiers and release notes referenced below for details.

Impact

A local attacker could gain root privileges (CVE-2011-1444, fixed in chromium-11.0.696.57).

A context-dependent attacker could entice a user to open a specially crafted web site or JavaScript program using Chromium or V8, possibly resulting in the execution of arbitrary code with the privileges of the process, or a Denial of Service condition. The attacker also could obtain cookies and other sensitive information, conduct man-in-the-middle attacks, perform address bar spoofing, bypass the same origin policy, perform Cross-Site Scripting attacks, or bypass pop-up blocks.

Workaround

There is no known workaround at this time.

Resolution

All Chromium users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=www-client/chromium-15.0.874.102"
 

All V8 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/v8-3.5.10.22"
 

References

Release Date
November 01, 2011

Latest Revision
November 01, 2011: 1

Severity
high

Exploitable
remote

Bugzilla entries