phpDocumentor: Function call injection — GLSA 201111-04

phpDocumentor bundles Smarty which contains an input sanitation flaw, allowing attackers to call arbitrary PHP functions.

Affected Packages

dev-php/PEAR-PhpDocumentor on all architectures
Affected versions < 1.4.3-r1
Unaffected versions >= 1.4.3-r1

Background

The phpDocumentor package provides automatic documenting of PHP API directly from the source.

Description

phpDocumentor bundles Smarty with the modifier.regex_replace.php plug-in which does not properly sanitize input related to the ASCII NUL character in a search string.

Impact

A remote attacker could call arbitrary PHP functions via templates.

Workaround

There is no known workaround at this time.

Resolution

All phpDocumentor users should upgrade to the latest stable version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=dev-php/PEAR-PhpDocumentor-1.4.3-r1"
 

NOTE: This is a legacy GLSA. Updates for all affected architectures are available since February 12, 2011. It is likely that your system is already no longer affected by this issue.

References

Release Date
November 11, 2011

Latest Revision
November 11, 2011: 1

Severity
normal

Exploitable
remote

Bugzilla entries