libvirt: Multiple vulnerabilities — GLSA 201202-07

Multiple vulnerabilities were found in libvirt, the worst of which might allow guest OS users to read arbitrary files on the host OS.

Affected Packages

app-emulation/libvirt on all architectures
Affected versions < 0.9.3-r1
Unaffected versions >= 0.9.3-r1

Background

libvirt is a C toolkit to manipulate virtual machines.

Description

Multiple vulnerabilities have been discovered in libvirt. Please review the CVE identifiers referenced below for details.

Impact

These vulnerabilities allow a remote attacker to cause a Denial of Service condition on the host server or libvirt daemon, or might allow guest OS users to read arbitrary files on the host OS.

Workaround

There is no known workaround at this time.

Resolution

All libvirt users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/libvirt-0.9.3-r1"
 

References

Release Date
February 27, 2012

Latest Revision
February 27, 2012: 1

Severity
normal

Exploitable
local, remote

Bugzilla entries