libmikmod: User-assisted execution of arbitrary code — GLSA 201203-10

Multiple buffer overflow vulnerabilities in libmikmod may allow an attacker to execute arbitrary code or cause a Denial of Service condition.

Affected Packages

media-libs/libmikmod on all architectures
Affected versions < 3.2.0_beta2-r3
Unaffected versions >= 3.2.0_beta2-r3, revision >= 3.1.12-r1

Background

libmikmod is a library to play a wide range of module formats.

Description

Multiple boundary errors have been found in load_it.c in libmikmod, which may cause a buffer overflow.

Impact

A remote attacker could entice a user to open specially crafted files in an application linked against libmikmod, possibly resulting in execution of arbitrary code with the permissions of the user running the application, or Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All libmikmod 3.2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose
 ">=media-libs/libmikmod-3.2.0_beta2-r3"
 

All libmikmod 3.1 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libmikmod-3.1.12-r1"
 

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

References

Release Date
March 06, 2012

Latest Revision
March 06, 2012: 1

Severity
normal

Exploitable
remote

Bugzilla entries