Multiple buffer overflow vulnerabilities in libmikmod may allow an attacker to execute arbitrary code or cause a Denial of Service condition.
|Package||media-libs/libmikmod on all architectures|
|Affected versions||< 3.2.0_beta2-r3|
|Unaffected versions||>= 3.2.0_beta2-r3, revision >= 3.1.12-r1|
libmikmod is a library to play a wide range of module formats.
Multiple boundary errors have been found in load_it.c in libmikmod, which may cause a buffer overflow.
A remote attacker could entice a user to open specially crafted files in an application linked against libmikmod, possibly resulting in execution of arbitrary code with the permissions of the user running the application, or Denial of Service.
There is no known workaround at this time.
All libmikmod 3.2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libmikmod-3.2.0_beta2-r3"
All libmikmod 3.1 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libmikmod-3.1.12-r1"
Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.
March 06, 2012
March 06, 2012: 1