FreeType: Multiple vulnerabilities — GLSA 201204-04

Multiple vulnerabilities have been found in FreeType, allowing remote attackers to possibly execute arbitrary code or cause Denial of Service.

Affected Packages

media-libs/freetype on all architectures
Affected versions < 2.4.9
Unaffected versions >= 2.4.9

Background

FreeType is a high-quality and portable font engine.

Description

Multiple vulnerabilities have been discovered in FreeType. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted font, possibly resulting in execution of arbitrary code with the privileges of the user running the application, or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All FreeType users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/freetype-2.4.9"
 

References

Release Date
April 17, 2012

Latest Revision
April 17, 2012: 1

Severity
normal

Exploitable
remote

Bugzilla entries