Multiple vulnerabilities in Adobe Flash Player, the worst of which might allow remote attackers to execute arbitrary code.
|Package||www-plugins/adobe-flash on all architectures|
|Affected versions||< 18.104.22.168|
|Unaffected versions||>= 22.214.171.124|
The Adobe Flash Player is a renderer for the SWF file format, which is commonly used to provide interactive websites.
Multiple vulnerabilities have been discovered in Adobe Flash Player. Please review the CVE identifiers referenced below for details.
A remote attacker could entice a user to open a specially crafted SWF file, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition. Furthermore, a remote attacker may be able to bypass intended access restrictions, bypass cross-domain policy, inject arbitrary web script, or obtain sensitive information.
There is no known workaround at this time.
All Adobe Flash Player users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-plugins/adobe-flash-126.96.36.199"