OpenJPEG: User-assisted execution of arbitrary code — GLSA 201206-06

A vulnerability in OpenJPEG could result in execution of arbitrary code.

Affected Packages

media-libs/openjpeg on all architectures
Affected versions < 1.5.0
Unaffected versions >= 1.5.0

Background

OpenJPEG is an open-source JPEG 2000 library.

Description

An error in jp2.c of OpenJPEG could allow an out-of-bounds write error.

Impact

A remote attacker could entice a user to open a specially crafted JPEG file, possibly resulting in execution of arbitrary code or a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All OpenJPEG users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/openjpeg-1.5.0"
 

References

Release Date
June 21, 2012

Latest Revision
June 21, 2012: 1

Severity
normal

Exploitable
remote

Bugzilla entries