Multiple vulnerabilities in libpng might allow remote attackers to execute arbitrary code or cause a Denial of Service condition.
|Package||media-libs/libpng on all architectures|
|Affected versions||< 1.5.10|
|Unaffected versions||>= 1.5.10, revision >= 1.2.49, revision >= 1.2.50, revision >= 1.2.51, revision >= 1.2.52, revision >= 1.2.53, revision >= 1.2.54, revision >= 1.2.55|
libpng is a standard library used to process PNG (Portable Network Graphics) images. It is used by several programs, including web browsers and potentially server processes.
Multiple vulnerabilities have been discovered in libpng:
An attacker could exploit these vulnerabilities to execute arbitrary code with the permissions of the user running the vulnerable program, which could be the root user, or to cause programs linked against the library to crash.
There is no known workaround at this time.
All libpng 1.5 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.5.10"
All libpng 1.2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.49"
Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.