Multiple vulnerabilities have been found in GnuTLS, allowing a remote attacker to perform man-in-the-middle or Denial of Service attacks.
|Package||net-libs/gnutls on all architectures|
|Affected versions||< 2.12.18|
|Unaffected versions||>= 2.12.18|
GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.
Multiple vulnerabilities have been found in GnuTLS:
A remote attacker could perform man-in-the-middle attacks to spoof arbitrary SSL servers or cause a Denial of Service condition in applications linked against GnuTLS.
There is no known workaround at this time.
All GnuTLS users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.18"