GnuTLS: Multiple vulnerabilities — GLSA 201206-18

Multiple vulnerabilities have been found in GnuTLS, allowing a remote attacker to perform man-in-the-middle or Denial of Service attacks.

Affected Packages

net-libs/gnutls on all architectures
Affected versions < 2.12.18
Unaffected versions >= 2.12.18

Background

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.

Description

Multiple vulnerabilities have been found in GnuTLS:

  • An error in libgnutls does not properly sanitize "\0" characters from certificate fields (CVE-2009-2730).
  • An error in the TLS and SSL protocols mistreats renegotiation handshakes (CVE-2009-3555).
  • A boundary error in the "gnutls_session_get_data()" function in gnutls_session.c could cause a buffer overflow (CVE-2011-4128).
  • An error in the "_gnutls_ciphertext2compressed()" function in gnutls_cipher.c could cause memory corruption (CVE-2012-1573).

Impact

A remote attacker could perform man-in-the-middle attacks to spoof arbitrary SSL servers or cause a Denial of Service condition in applications linked against GnuTLS.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.18"
 

References

Release Date
June 23, 2012

Latest Revision
June 23, 2012: 1

Severity
normal

Exploitable
remote

Bugzilla entries