Apache Tomcat: Multiple vulnerabilities — GLSA 201206-24

Multiple vulnerabilities were found in Apache Tomcat, the worst of which allowing to read, modify and overwrite arbitrary files.

Affected packages

www-servers/tomcat on all architectures
Affected versions < 7.0.23
Unaffected versions revision >= 6.0.35
>= 7.0.23
revision >= 6.0.44
revision >= 6.0.45
revision >= 6.0.46
revision >= 6.0.47
revision >= 6.0.48


Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.


Multiple vulnerabilities have been discovered in Apache Tomcat. Please review the CVE identifiers referenced below for details.


The vulnerabilities allow an attacker to cause a Denial of Service, to hijack a session, to bypass authentication, to inject webscript, to enumerate valid usernames, to read, modify and overwrite arbitrary files, to bypass intended access restrictions, to delete work-directory files, to discover the server’s hostname or IP, to bypass read permissions for files or HTTP headers, to read or write files outside of the intended working directory, and to obtain sensitive information by reading a log file.


There is no known workaround at this time.


All Apache Tomcat 6.0.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/tomcat-6.0.35"

All Apache Tomcat 7.0.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/tomcat-7.0.23"


Release date
June 24, 2012

Latest revision
March 20, 2016: 3


local, remote

Bugzilla entries